JIT connections failing for agents on versions below 18.7.6

Incident Report for Teleport Cloud

Postmortem

A regression introduced in Teleport v18.7.6 broke the Just-in-Time (JIT) access flow when connecting to database agents running versions earlier than 18.7.6. The defect affected clusters on versions 18.7.6, 18.8.0, and 18.8.1. The 18.8.0 and (upcoming) 18.8.1 tenant upgrades would have impacted ~16% of Cloud customers, specifically those using database access. To prevent disruption, affected customers were rolled back to a stable version while the fix lands in 18.8.2.

Posted May 29, 2026 - 18:22 UTC

Resolved

Rollbacks to a stable cluster version have been completed successfully for all affected customers. We're now focused on developing a fix, which is expected to ship in the next version release.
Posted May 19, 2026 - 22:19 UTC

Monitoring

We are actively rolling back any customers cluster version to 18.7.4 and will continue to monitor.
Posted May 19, 2026 - 18:59 UTC

Update

We've confirmed that the regression only affects database agents running versions below 18.7.6 when connecting to clusters on 18.7.6, 18.8.0, or 18.8.1.
Posted May 19, 2026 - 14:27 UTC

Identified

We've identified a regression introduced in v18.7.6 that breaks the JIT flow when connecting to agents running versions below 18.7.6. The issue is present in cluster versions 18.7.6, 18.8.0, and 18.8.1, and affects a subset of customers.

We are still confirming which agent types are impacted and will share a list shortly. We'll provide another update as mitigation rolls out.
Posted May 19, 2026 - 13:59 UTC
This incident affected: Cloud Service.