SSH access interruptions due to v18.2.1 rollout

Incident Report for Teleport Cloud

Resolved

Cloud tenants previously running 18.2.1 or 18.2.2 have been rolled back to 18.2.0.
Posted Sep 24, 2025 - 19:48 UTC

Identified

Rollsback to v18.2.0 is progressing.
Posted Sep 24, 2025 - 18:24 UTC

Investigating

Some Cloud tenants upgraded to v18.2.1 on 9/24 at 16 UTC are unable to access resources via SSH. Rollback to v18.2.0 is in progress.
Posted Sep 24, 2025 - 18:23 UTC
This incident affected: Cloud Service.