Billing Summary Page
Incident Report for Teleport Cloud
Postmortem

The root cause of this issue was an engineering mistake when adding a new field to the database. The impact was isolated to customers on usage based plans who attempted to view their Billing Summary during the impacted period. Additional tests and measures have been put in place to prevent this from happening in the future. No further action is required.

Timeline

On October 04, 2024, a database change was deployed to Teleport Cloud that added a new unused field. This change mistakenly passed an incorrect ID to the method, causing requests to the billing summary endpoint to fail.

On October 07, 2024, a customer reported an issue with their Billing Summary page. The fix was deployed for all customers three hours later.

Posted Oct 10, 2024 - 22:15 UTC

Resolved
This incident has been resolved.
Posted Oct 07, 2024 - 15:04 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 07, 2024 - 13:27 UTC
Identified
The issue has been identified and we are working on deploying a fix.
Posted Oct 07, 2024 - 11:38 UTC
Investigating
We're investigating reported issues with the billing summary page. For some users it is unable to retrieve account information.
Posted Oct 07, 2024 - 11:36 UTC