Teleport Cloud Signups - Failure to create new Cloud tenant

Incident Report for Teleport Cloud

Resolved

This incident has been resolved.
Posted Jul 22, 2025 - 00:37 UTC

Identified

Teleport Cloud Signups rely on Let's Encrypt for Certificate generation. Let's Encrypt is currently experiencing an outage which blocks the creation of new signups. This does not impact existing Teleport Cloud clusters.
Posted Jul 21, 2025 - 19:06 UTC
This incident affected: Cloud Signups.