Windows Desktop access interruptions due to v18.3.1 rollout

Incident Report for Teleport Cloud

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 02:55 UTC

Monitoring

Teleport Agents that were upgraded to v18.3.1 and have Windows Desktop access configured were scheduled to be downgraded to v18.2.8 during the next configured maintenance window.
Posted Nov 17, 2025 - 17:26 UTC

Identified

Following Teleport Tenants’ upgrade to v18.3.1, some Teleport agents were auto-upgraded to v18.3.1 and are unable to access resources via Windows Desktop. Rollout of Teleport v18.3.1 was suspended.
Posted Nov 17, 2025 - 13:20 UTC
This incident affected: Cloud Service.