Teleport us-west-2 connectivity

Incident Report for Teleport Cloud

Resolved

This incident has been resolved.
Posted Jul 24, 2026 - 13:20 UTC

Monitoring

We are monitoring AWS and will ensure services are restored once AWS services are available.
Posted Jul 24, 2026 - 12:37 UTC

Identified

AWS is experiencing connectivity issues in its us-west-2 region which is impacting Teleport Cloud services in that region. Single region Teleport clusters in us-west-2 may see disruption.

We are monitoring AWS and will ensure services are restored once AWS services are available.

https://health.aws.amazon.com/health/status
Posted Jul 24, 2026 - 11:53 UTC
This incident affected: Cloud Service.