Teleport Cloud Outage

Incident Report for Teleport Cloud

Postmortem

On October 20, 2025, between 06:48 and 22:07 UTC, some Teleport Cloud customers experienced issues connecting to their cluster. These issues were triggered by an AWS outage impacting the US East region (N. Virginia: us-east-1). The severity of the impact was dependent on the type of Teleport Cloud deployment and where users or agents were located.

  • Customers with single-region auth service deployments in the US East region were unable to connect to their cluster
  • Customers with multi-region auth service deployments in the US East region experienced intermittent connectivity issues
  • Users and agents located near the US East region experienced intermittent connectivity issues

For more details, please download the full RCA:
RCA: 2025-10-20 US East Region Connectivity

Posted Oct 31, 2025 - 17:11 UTC

Resolved

The issue has been resolved and all services have been restored.
Posted Oct 20, 2025 - 09:49 UTC

Investigating

AWS is experiencing an outage in its us-east-1 region which is impacting Teleport Cloud services in that region. Teleport clusters whose primary auth region is us-east-1 are unavailable.

We are monitoring AWS and will ensure services are restored once AWS services are available.

https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 09:46 UTC
This incident affected: Cloud Service and Cloud Signups.