SSH connections failing for agents on 18.8.2

Incident Report for Teleport Cloud

Resolved

This incident has been resolved.
Posted Jun 01, 2026 - 21:17 UTC

Update

This was an isolated incident and does not appear to be impacting other customers at this time. We will continue to monitor the situation closely and provide updates as necessary.
Posted Jun 01, 2026 - 21:17 UTC

Investigating

We have identified a regression introduced in 18.8.2 that can impact agent SSH connectivity. We will be rolling back agents to 18.7.4 and will provide an update when this is complete.
Posted Jun 01, 2026 - 17:59 UTC
This incident affected: Cloud Service.