Agent Version Upgrade

Incident Report for Teleport Cloud

Resolved

Some customers using deprecated apt or rpm managed update systems were automatically misconfigured to update agents to an unavailable version. The misconfiguration has been addressed by locking all agent versions to 18.9.1 for Cloud Tenants running 18.9.1 or 18.9.2.

v18 tenants will be upgraded to 18.10.0 by end of next week and agents will update to 18.10.0 during normal scheduled maintenance windows.
Posted Jul 14, 2026 - 17:32 UTC

Identified

Newly created agents may fail to join a Cloud deployment. We've identified the root cause and are actively working on a fix.
Posted Jul 14, 2026 - 16:41 UTC

Investigating

We are investigating issues with agent upgrades and will provide updates here soon.
Posted Jul 14, 2026 - 16:36 UTC
This incident affected: Cloud Service.