Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 30, 2025 - 16:00 UTC
Scheduled
This message does not affect customers running Teleport versions newer than v16.4.8.
- Teleport Cloud customers on 15.x will be automatically upgraded to 15.4.33 during their selected upgrade window. - Customers on older major versions will also be upgraded, provided all agents are compatible with the next major version.
Cloud customers running a version older than v16.4.8 must upgrade to a newer version to receive in-cluster upgrade notifications, which are personalized to your cluster, ensuring you receive timely and relevant updates about changes that impact your cluster. All customers are encouraged to upgrade to the latest version to take advantage of the newest features and improvements.
Posted Apr 29, 2025 - 21:51 UTC
This scheduled maintenance affected: Cloud Service.