Email Validation

Incident Report for Teleport Cloud

Resolved

This incident has been resolved.
Posted May 14, 2025 - 22:40 UTC

Identified

Teleport Cloud's email validation service provider is experiencing intermittent API errors. This impacts cloud trial signups and managing contacts in Teleport clusters.
Posted May 14, 2025 - 20:35 UTC
This incident affected: Cloud Service and Cloud Signups.