New Tenant Onboarding Failures

Incident Report for Teleport Cloud

Resolved

This incident has been resolved.
Posted Mar 10, 2026 - 16:16 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 10, 2026 - 11:36 UTC

Investigating

We're currently investigating an issue that prevents new tenants from onboarding.
Posted Mar 10, 2026 - 10:22 UTC
This incident affected: Cloud Signups.