Cloud API Degradation

Incident Report for Teleport Cloud

Resolved

The fix has been deployed, we've confirmed that the latency should no longer be occurring.
Posted Oct 31, 2024 - 14:49 UTC

Identified

We are aware of an issue causing slowness in Cloud's API, impacting deployment of new tenants, billing dashboard access, downloads, and other services. Our team has identified the cause and is actively releasing a fix.
Posted Oct 31, 2024 - 14:31 UTC