New Tenant Onboarding Failures

Incident Report for Teleport Cloud

Resolved

The incident has been resolved.
Posted Jun 11, 2026 - 18:40 UTC

Identified

The issue has been identifier and a fix is being implemented.
Posted Jun 11, 2026 - 17:06 UTC

Investigating

We are currently investigating the issue.
Posted Jun 11, 2026 - 17:03 UTC
This incident affected: Cloud Signups.